We're pleased to confirm that the hotfix for servers provisioned within the past 24 hours has now been completed. These servers should have NGINX installed correctly and shouldn't experience any further issues moving forward.
For all existing servers, NGINX should continue to run as expected. However, the erroneous repository may still be present on your server and could cause issues with future package installations or updates. To resolve this, please follow the steps outlined in our related incident here: https://status.on-forge.com/incidents/ftjtydv9l555
We'd like to sincerely apologise for the disruption this incident has caused. This issue stemmed from an unexpected change to a third-party repository that we, along with much of the wider Ubuntu and Laravel community, have relied upon for some time.
That said, we fully recognise the responsibility we hold to keep your infrastructure running smoothly, and we understand how disruptive an incident like this can be — particularly when it affects provisioning and day-to-day server management. We are actively conducting an internal review to understand how we can better insulate Forge from sudden upstream changes like this in the future, including evaluating our repository dependencies and improving our ability to respond quickly when third-party services change unexpectedly.
Thank you for your continued trust, patience, and understanding. We truly appreciate it, and we're committed to doing better.
Posted Apr 27, 2026 - 10:07 UTC
Monitoring
We're pleased to share that a fix has been successfully deployed for new server provisioning, and it's performing as expected. NGINX is now available again on all newly provisioned servers.
For any servers that were provisioned within the past 24 hours, we're rolling out a hotfix that will automatically update the repository and reinstall NGINX, ensuring those servers are brought fully in line with the new configuration.
As part of our normal development cycle, we'll also be updating all existing servers to use the new repository. This will ensure that every supported server continues to receive ongoing updates reliably moving forward.
We'll share another update once the hotfix has been fully rolled out. Thank you again for your patience throughout this incident — we truly appreciate it.
Posted Apr 27, 2026 - 09:02 UTC
Update
We've developed a fix for the NGINX provisioning issue and are currently validating it across all supported providers to ensure stability before rolling it out. Our engineering team is conducting thorough testing to confirm that server provisioning, including NGINX installation, will function reliably once deployed.
We'll provide a further update as soon as testing is complete and the fix has been deployed to production. We appreciate your patience and understanding while we work to resolve this.
Posted Apr 27, 2026 - 08:26 UTC
Identified
We're currently seeing an issue with server provisioning across multiple providers. The NGINX repository we rely on from Ondrej (https://launchpad.net/~ondrej/+archive/ubuntu/nginx) has been dropped, which is causing provisioning to fail.
Our engineering team is on it and actively working on a fix. In the meantime, server provisioning may still go through, but it likely won't include NGINX.
Thanks for your patience while we sort this out — we'll share an update as soon as we have one!
Posted Apr 27, 2026 - 07:52 UTC
This incident affected: Forge Control Panel and Laravel VPS (Servers).