Certificate Renewals

Incident Report for Laravel Forge

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:17 UTC

Investigating

We are aware of an issue affecting domain certificate generation due to the ongoing Cloudflare incident which may cause some certificates to become stuck in "Activating" status. Our engineering team is continuing to monitor and will provide a status update when the Cloudflare network starts to recover.
Posted Nov 18, 2025 - 13:27 UTC
This incident affected: Certificates.