Monitoring - Let's Encrypt certificate issuance

Incident Report for Laravel Forge

Resolved

The issue has now been resolved and Let's Encrypt is fully operational.
Posted Jun 19, 2026 - 07:20 UTC

Monitoring

We're monitoring degraded API performance at Let's Encrypt, an upstream certificate provider. As a result, you may experience intermittent failures when issuing or renewing Let's Encrypt certificates for your Forge sites. Existing certificates are unaffected. We'll post an update as soon as service is restored.
Posted Jun 18, 2026 - 20:28 UTC
This incident affected: Certificates.