Resolved - Degraded performance on Forge control panel

Incident Report for Laravel Forge

Resolved

The degraded performance affecting the Forge control panel has been resolved. Page loads and responsiveness should be back to normal.

If you're still experiencing any issues, please reach out to our Support Team who will be happy to help. We apologise for any inconvenience caused.
Posted May 18, 2026 - 14:25 UTC

Investigating

We're currently investigating degraded performance affecting the Forge control panel. Some users may experience slow page loads or timeouts when managing their servers and sites.

Our engineering team is actively looking into this and we'll provide updates as we learn more.
Posted May 18, 2026 - 14:01 UTC
This incident affected: Forge Control Panel.